[help] Installing pycdio

[help] Installing pycdio:

I am trying to install pycdio. I downloaded pycdio-0.21.tar.gz and extracted it. Made sure all the requirements were met. I know almost nothing about python. Ran sudo pip install matplotlib & sudo pip install scipy

I get the following:

$~/Software/pycdio-0.21$ sudo python setup.py install
running install
running bdist_egg
running egg_info
writing pycdio.egg-info/PKG-INFO
writing top-level names to pycdio.egg-info/top_level.txt
writing dependency_links to pycdio.egg-info/dependency_links.txt
reading manifest file ‘pycdio.egg-info/SOURCES.txt’
reading manifest template ‘MANIFEST.in’
warning: no previously-included files found matching ‘swig/cdtext.swg’
writing manifest file ‘pycdio.egg-info/SOURCES.txt’
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib.linux-x86_64-2.7
copying cdio.py -> build/lib.linux-x86_64-2.7
copying iso9660.py -> build/lib.linux-x86_64-2.7
copying pycdio.py -> build/lib.linux-x86_64-2.7
copying pyiso9660.py -> build/lib.linux-x86_64-2.7
running build_ext
building ’_pycdio’ extension
swigging swig/pycdio.i to swig/pycdio_wrap.c
swig -python -outdir /home/frank/Software/pycdio-0.21 -o swig/pycdio_wrap.c swig/pycdio.i
swig/pycdio.i:42: Error: Unable to find ‘cdtext.swg’
error: command ‘swig’ failed with exit status 1


apt list –installed | grep libcdio
libcdio-cdda1/xenial,now 0.83-4.2ubuntu1 amd64 [installed]
libcdio-dev/xenial,now 0.83-4.2ubuntu1 amd64 [installed]
libcdio-paranoia1/xenial,now 0.83-4.2ubuntu1 amd64 [installed]
libcdio13/xenial,now 0.83-4.2ubuntu1 amd64 [installed]

apt list –installed | grep swig
swig/xenial,now 3.0.8-0ubuntu3 amd64 [installed]
swig3.0/xenial,now 3.0.8-0ubuntu3 amd64 [installed,automatic]

apt list –installed | grep pkg-config
pkg-config/xenial,now 0.29.1-0ubuntu1 amd64 [installed]

apt list –installed | grep python-dev
libpython-dev/xenial,now 2.7.11-1 amd64 [installed,automatic]
python-dev/xenial,now 2.7.11-1 amd64 [installed,automatic]

apt list –installed | grep libiso9660-dev
libiso9660-dev/xenial,now 0.83-4.2ubuntu1 amd64 [installed]

submitted by /u/alicetilldeath
[link] [comments] via Linux 101 stuff. Questions are encouraged, noobs are welcome!