[PSA] NVIDIA 387.22 drivers and some mobile graphics chipsets have issues with vulkan

[PSA] NVIDIA 387.22 drivers and some mobile graphics chipsets have issues with vulkan:

Hi,

I spent half a day or so last weekend trying to get F1 (2017) running on my laptop with the latest short lived NVIDIA drivers (387.22), on my ArchLinux install.

I couldn’t get F1 to start properly, and kept receiving errors like ‘vkCreateSwapchainKHR failed: -1’. I then tested vkQuake and received a similar error, which is a game I had run OK some time ago.

After falling back to an earlier driver release (378.13) and kernel, F1 and vkQuake began rendering fine.

I did a little bit of digging and there are at least a couple of other people reporting the same issues with mobile NVIDIA graphics and the latest NVIDIA driver, see here: http://ift.tt/2yDexvM

So just a heads up that if you’re running a mobile NVIDIA chipset and trying to use the latest drivers + vulkan you might run into trouble.

Also, I submitted a bug report by email to their ‘linux-bugs’ address but haven’t had any response. Hopefully the issue gets seen to soon.

submitted by /u/DarwinKamikaze
[link] [comments] via GNU/Linux Gaming on Reddit