No wifi on openSUSE Leap 42.3

No wifi on openSUSE Leap 42.3:

Hello. I just installed Leap on my newly built pc but, I can’t for the better of me get the wifi to work. The wifi module is integrated on my Asus maximus ix code motherboard, and is realtek. So what can I do?

sudo hwinfo --netcard 22: PCI 1f.6: 0200 Ethernet controller [Created at pci.378] Unique ID: rBUF.SqYnJCWejiC SysFS ID: /devices/pci0000:00/0000:00:1f.6 SysFS BusID: 0000:00:1f.6 Hardware Class: network Model: "Intel Ethernet Connection (2) I219-V" Vendor: pci 0x8086 "Intel Corporation" Device: pci 0x15b8 "Ethernet Connection (2) I219-V" SubVendor: pci 0x1043 "ASUSTeK Computer Inc." SubDevice: pci 0x8672 Driver: "e1000e" Driver Modules: "e1000e" Device File: eth0 Memory Range: 0xdff00000-0xdff1ffff (rw,non-prefetchable) IRQ: 154 (22 events) HW Address: 2c:fd:a1:e0:26:d2 Permanent HW Address: 2c:fd:a1:e0:26:d2 Link detected: no Module Alias: "pci:v00008086d000015B8sv00001043sd00008672bc02sc00i00" Driver Info #0: Driver Status: e1000e is active Driver Activation Cmd: "modprobe e1000e" Config Status: cfg=no, avail=yes, need=no, active=unknown 25: PCI 400.0: 0280 Network controller [Created at pci.378] Unique ID: YmUS.KuztIuqw8CA Parent ID: qTvu.eWH1hJn0Vm9 SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:04:00.0 SysFS BusID: 0000:04:00.0 Hardware Class: network Model: "Realtek Network controller" Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd." Device: pci 0xb822 SubVendor: pci 0x1043 "ASUSTeK Computer Inc." SubDevice: pci 0x8746 I/O Ports: 0xd000-0xdfff (rw,disabled) Memory Range: 0xdfd00000-0xdfd0ffff (rw,non-prefetchable,disabled) IRQ: 10 (no events) Module Alias: "pci:v000010ECd0000B822sv00001043sd00008746bc02sc80i00" Config Status: cfg=no, avail=yes, need=no, active=unknown Attached to: #14 (PCI bridge) 

submitted by /u/SeriouslyTM
[link] [comments] via Linux 101 stuff. Questions are encouraged, noobs are welcome!